Facebook SDK

 Tunnel merupakan suatu cara atau metode untuk menghubungkan dua buah network yang menggunakan jalur terowongan dalam internet. Metode tunnel ini banyak digunakan oleh perusahaan yang mempunyai kantor cabang yang letaknya jauh. Misalkan ada sebuah perusahaan besar berpusat di Solo. Nah, perusahaan tersebut mempunyai kantor cabang di Sragen. Ketika kantor pusat yang di Solo ingin mengirimkan data ke kantor cabang di Sragen maka digunakanlah metode Tunnel ini. Data akan dikirimkan dengan jalur terowongan yang disebut tunnel menggunakan media internet. Jadi, nantinya kita hanya membutuhkan koneksi internet di kedua kantor agar data bisa terkirim.

Topologi :

Konfigurasi :

Pertama, setting IP Address beserta netmask di seluruh device sesuai topologi.

SOLO(config)#interface fa0/0
SOLO(config­if)#no shutdown
SOLO(config­if)#ip address 11.11.11.1 255.255.255.0
SOLO(config­if)#exit
SOLO(config)#interface fa0/1
SOLO(config­if)#no shutdown
SOLO(config­if)#ip address 192.168.1.1 255.255.255.0
SOLO(config­if)#exit
SOLO(config)#
SRAGEN(config)#interface fa0/0
SRAGEN(config­if)#no shutdown
SRAGEN(config­if)#ip address 22.22.22.1 255.255.255.0
SRAGEN(config­if)#exit
SRAGEN(config)#interface fa0/1
SRAGEN(config­if)#no shutdown
SRAGEN(config­if)#ip address 192.168.2.1 255.255.255.0
SRAGEN(config­if)#exit
SRAGEN(config)#
INTERNET(config)#interface fa0/0
INTERNET(config­if)#no shutdown
INTERNET(config­if)#ip address 11.11.11.2 255.255.255.0
INTERNET(config­if)#exit
INTERNET(config)#interface fa0/1
INTERNET(config­if)#no shutdown
INTERNET(config­if)#ip address 22.22.22.2 255.255.255.0
INTERNET(config­if)#exit
INTERNET(config)#

Selanjutnya, kita konfigurasi routing agar ketiga network dapat terhubung. Kita konfigurasikan hanya network yang terhubung ke INTERNET. Dua network local tidak karena nantinya akan dihubungkan melalui Tunnel.

SOLO(config)#router eigrp 100
SOLO(config­router)#network 11.11.11.0
SOLO(config­router)#no auto­summary
SOLO(config­router)#exit
SOLO(config)#
SRAGEN(config)#router eigrp 100
SRAGEN(config­router)#network 22.22.22.0
SRAGEN(config­router)#no auto­summary
SRAGEN(config­router)#exit
SRAGEN(config)#
INTERNET(config)#router eigrp 100
INTERNET(config­router)#network 11.11.11.0
INTERNET(config­router)#
%DUAL­5­NBRCHANGE: IP­EIGRP 100: Neighbor 11.11.11.1
(FastEthernet0/0) is up: new adjacency
INTERNET(config­router)#network 22.22.22.0
INTERNET(config­router)#
%DUAL­5­NBRCHANGE: IP­EIGRP 100: Neighbor 22.22.22.1
(FastEthernet0/1) is up: new adjacency
INTERNET(config­router)#no auto­summary
INTERNET(config­router)#
%DUAL­5­NBRCHANGE: IP­EIGRP 100: Neighbor 11.11.11.1
(FastEthernet0/0) resync: summary configured
%DUAL­5­NBRCHANGE: IP­EIGRP 100: Neighbor 22.22.22.1
(FastEthernet0/1) resync: summary configured
INTERNET(config­router)#exit
INTERNET(config)#

Selanjutnya, konfigurasi Tunnel di router SOLO dan SRAGEN.

SOLO(config)#interface tunnel 0
SOLO(config­if)#ip address 100.100.100.1 255.255.255.0
SOLO(config­if)#tunnel source fa0/0
SOLO(config­if)#tunnel destination 22.22.22.1
SOLO(config­if)#exit
SOLO(config)#
SRAGEN(config)#interface tunnel 0
SRAGEN(config­if)#ip address 100.100.100.2 255.255.255.0
SRAGEN(config­if)#tunnel source fa0/0
SRAGEN(config­if)#tunnel destination 11.11.11.1
SRAGEN(config­if)#exit
SRAGEN(config)#

Keterangan :

  • tunnel source fa0/0 : Interface router yang directly connected dengan INTERNET.
  • tunnel destination 11.11.11.1 : IP Address dari Interface router lawan yang
    directly connected dengan INTERNET.

Selanjutnya, test ping antar client.

Sakti-PC1 ping Sakti-PC2

Packet Tracer PC Command Line 1.0
C:>ping 192.168.2.254
Pinging 192.168.2.254 with 32 bytes of data:
Reply from 192.168.1.1: Destination host unreachable.
Reply from 192.168.1.1: Destination host unreachable.
Reply from 192.168.1.1: Destination host unreachable.
Reply from 192.168.1.1: Destination host unreachable.
Ping statistics for 192.168.2.254:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
C:>
Packet Tracer PC Command Line 1.0
C:>ping 192.168.1.254
Pinging 192.168.1.254 with 32 bytes of data:
Reply from 192.168.2.1: Destination host unreachable.
Reply from 192.168.2.1: Destination host unreachable.
Reply from 192.168.2.1: Destination host unreachable.
Reply from 192.168.2.1: Destination host unreachable.
Ping statistics for 192.168.1.254:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
C:>

Terlihat bahwa kedua network belum terhubung. Agar bisa, terlebih dahulu kita setting static routing dimana gateway yang digunakan adalah IP Address interface tunnel.

SOLO

SOLO(config)#ip route 192.168.2.0 255.255.255.0 100.100.100.2
SOLO(config)#

Lihat tabel routing :

SOLO#show ip route 
Codes: C ­ connected, S ­ static, I ­ IGRP, R ­ RIP, M ­
mobile, B ­ BGP
D ­ EIGRP, EX ­ EIGRP external, O ­ OSPF, IA ­ OSPF inter area
N1 ­ OSPF NSSA external type 1, N2 ­ OSPF NSSA external type 2
E1 ­ OSPF external type 1, E2 ­ OSPF external type 2, E ­ EGP
i ­ IS­IS, L1 ­ IS­IS level­1, L2 ­ IS­IS level­2, ia ­ IS­IS
inter area­ candidate default, U ­ per­user static route, o ­ ODR
P ­ periodic downloaded static route
Gateway of last resort is not set
11.0.0.0/24 is subnetted, 1 subnets
C 11.11.11.0 is directly connected, FastEthernet0/0
22.0.0.0/24 is subnetted, 1 subnets
D 22.22.22.0 [90/30720] via 11.11.11.2, 01:35:39,
FastEthernet0/0
100.0.0.0/24 is subnetted, 1 subnets
C 100.100.100.0 is directly connected, Tunnel0
C 192.168.1.0/24 is directly connected, FastEthernet0/1
S 192.168.2.0/24 [1/0] via 100.100.100.2
SOLO#

SRAGEN

SRAGEN(config)#ip route 192.168.1.0 255.255.255.0 100.100.100.1
SRAGEN(config)#

Lihat tabel routing :

SRAGEN#show ip route 
Codes: C ­ connected, S ­ static, I ­ IGRP, R ­ RIP, M ­
mobile, B ­ BGP
D ­ EIGRP, EX ­ EIGRP external, O ­ OSPF, IA ­ OSPF inter area
N1 ­ OSPF NSSA external type 1, N2 ­ OSPF NSSA external type 2
E1 ­ OSPF external type 1, E2 ­ OSPF external type 2, E ­ EGP
i ­ IS­IS, L1 ­ IS­IS level­1, L2 ­ IS­IS level­2, ia ­ IS­IS
inter area candidate default, U ­ per­user static route, o ­ ODR
P ­ periodic downloaded static route
Gateway of last resort is not set
11.0.0.0/24 is subnetted, 1 subnets
D 11.11.11.0 [90/30720] via 22.22.22.2, 01:36:08,
FastEthernet0/0
22.0.0.0/24 is subnetted, 1 subnets
C 22.22.22.0 is directly connected, FastEthernet0/0
100.0.0.0/24 is subnetted, 1 subnets
C 100.100.100.0 is directly connected, Tunnel0
S 192.168.1.0/24 [1/0] via 100.100.100.1
C 192.168.2.0/24 is directly connected, FastEthernet0/1
SRAGEN#

Coba test ping lagi antar client

Sakti-PC1 ping Sakti-PC2

C:>ping 192.168.2.254
Pinging 192.168.2.254 with 32 bytes of data:
Reply from 192.168.2.254: bytes=32 time=56ms TTL=126
Reply from 192.168.2.254: bytes=32 time=89ms TTL=126
Reply from 192.168.2.254: bytes=32 time=52ms TTL=126
Reply from 192.168.2.254: bytes=32 time=93ms TTL=126
Ping statistics for 192.168.2.254:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli­seconds:
Minimum = 52ms, Maximum = 93ms, Average = 72ms
C:>

Sakti-PC2 Ping Sakti-PC1

C:>ping 192.168.1.254
Pinging 192.168.1.254 with 32 bytes of data:
Reply from 192.168.1.254: bytes=32 time=42ms TTL=126
Reply from 192.168.1.254: bytes=32 time=66ms TTL=126
Reply from 192.168.1.254: bytes=32 time=53ms TTL=126
Reply from 192.168.1.254: bytes=32 time=62ms TTL=126
Ping statistics for 192.168.1.254:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli­seconds:
Minimum = 42ms, Maximum = 66ms, Average = 55ms
C:>

Coba traceroute. Terlihat bahwa jalur yang dilalui adalah dengan IP Tunnel.

C:>tracert 192.168.2.254
Tracing route to 192.168.2.254 over a maximum of 30 hops:
1 21 ms 18 ms 15 ms 192.168.1.1
2 30 ms 37 ms 33 ms 100.100.100.2
3 73 ms 46 ms 51 ms 192.168.2.254
Trace complete.
C:>
C:>tracert 192.168.1.254
Tracing route to 192.168.1.254 over a maximum of 30 hops:
1 14 ms 15 ms 13 ms 192.168.2.1
2 56 ms 36 ms 31 ms 100.100.100.1
3 36 ms 42 ms 65 ms 192.168.1.254
Trace complete.
C:>


Post a Comment

Previous Post Next Post