mengenai dasar redistribution. Secara default, router hanya meng-advertise dan berbagi route dengan router lain yang menjalankan protokol yang sama. Nah, misal jika kita memiliki banyak router yang mana tiap router mempunyai tipe routing yang berbeda misal Sakti-R1 menggunakan OSPF dan Sakti-R2 menggunakan EIGRP, dan kita ingin agar tiap routing tersebut dapat terhubung, mengetahui route satu sama lain dan juga dapat saling bertukar data, maka kita gunakan fitur redistribution ini. Dengan kita gunakan konfigurasi reditribuion ini berarti tiap tipe routing akan mengambil route dari tipe routing lain dan mendistribusikannya ke protocol lain pula.
Redistribution berfungsi untuk mengubungkan tipe-tipe routing yang telah dibahas di part sebelumnya. Tipe routing yang dapat diredistribute dapat berupa static routing maupun dynamic routing.
Topologi :
Konfigurasi :
Pertama, Set IP Address beserta netmask di semua device sesuai topologi.
SaktiR1(config)#interface fa0/0
SaktiR1(configif)#no shutdown
SaktiR1(configif)#ip address 11.11.11.1 255.255.255.0
SaktiR1(configif)#exit
SaktiR1(config)#
SaktiR2(config)#interface fa0/0
SaktiR2(configif)#no shutdown
SaktiR2(configif)#ip address 11.11.11.2 255.255.255.0
SaktiR2(configif)#exit
SaktiR2(config)#interface fa0/1
SaktiR2(configif)#no shutdown
SaktiR2(configif)#ip address 101.101.101.1 255.255.255.0
SaktiR2(configif)#exit
SaktiR2(config)#
SaktiR3(config)#interface fa0/0
SaktiR3(configif)#no shutdown
SaktiR3(configif)#ip address 102.102.102.1 255.255.255.0
SaktiR3(configif)#exit
SaktiR3(config)#interface fa0/1
SaktiR3(configif)#no shutdown
SaktiR3(configif)#ip address 12.12.12.1 255.255.255.0
SaktiR3(configif)#exit
SaktiR3(config)#
SaktiR4(config)#interface fa0/0
SaktiR4(configif)#no shutdown
SaktiR4(configif)#ip address 12.12.12.2 255.255.255.0
SaktiR4(configif)#exit
SaktiR4(config)#
SaktiR5(config)#interface fa0/0
SaktiR5(configif)#no shutdown
SaktiR5(configif)#ip address 13.13.13.1 255.255.255.0
SaktiR5(configif)#exit
SaktiR5(config)#
SaktiR6(config)#interface fa0/1
SaktiR6(configif)#no shutdown
SaktiR6(configif)#ip address 13.13.13.2 255.255.255.0
SaktiR6(configif)#exit
SaktiR6(config)#interface fa0/0
SaktiR6(configif)#no shutdown
SaktiR6(configif)#ip address 103.103.103.1 255.255.255.0
SaktiR6(configif)#exit
SaktiR6(config)#
aktiR7(configif)#ip address 104.104.104.1 255.255.255.0
SaktiR7(configif)#exit
SaktiR7(config)#interfacce fa0/1
SaktiR7(configif)#no shutdown
SaktiR7(configif)#ip address 14.14.14.1 255.255.255.0
SaktiR7(configif)#exit
SaktiR7(config)#
SaktiR8(config)#interface fa0/0
SaktiR8(configif)#no shutdown
SaktiR8(configif)#ip address 14.14.14.2 255.255.255.0
SaktiR8(configif)#exit
SaktiR8(config)#
SaktiR9(config)#interface fa0/0
SaktiR9(configif)#no shutdown
SaktiR9(configif)#ip address 101.101.101.2 255.255.255.0
SaktiR9(configif)#exit
SaktiR9(config)#interface fa0/1
SaktiR9(configif)#no shutdown
SaktiR9(configif)#ip address 102.102.102.2 255.255.255.0
SaktiR9(configif)#exit
SaktiR9(config)#interface fa1/0
SaktiR9(configif)#no shutdown
SaktiR9(configif)#ip addess 103.103.103.2 255.255.255.0
SaktiR9(configif)#exit
SaktiR9(config)#inteface fa1/1
SaktiR9(configif)#no shutdown
SaktiR9(configif)#ip address 104.104.104.2 255.255.255.0
SaktiR9(configif)#exit
SaktiR9(config)#
Selanjutnya kita set routing di masing-masing router sesuai topologi.
Sakti-R1 dengan Sakti-R2 untuk tipe RIPv2
SaktiR1(config)#router rip
SaktiR1(configrouter)#version 2
SaktiR1(configrouter)#network 11.11.11.0
SaktiR1(configrouter)#no autosummary
SaktiR1(configrouter)#exit
SaktiR1(config)#
SaktiR2(config)#router rip
SaktiR2(configrouter)#version 2
SaktiR2(configrouter)#network 11.11.11.0
SaktiR2(configrouter)#network 101.101.101.0
SaktiR2(configrouter)#no autosummary
SaktiR2(configrouter)#exit
SaktiR2(config)#
Cek output routng table di Sakti-R1
SaktiR1#show ip route
Codes: C connected, S static, I IGRP, R RIP, M
mobile, B BGP
D EIGRP, EX EIGRP external, O OSPF, IA OSPF inter area
N1 OSPF NSSA external type 1, N2 OSPF NSSA external type 2
E1 OSPF external type 1, E2 OSPF external type 2, E EGP
i ISIS, L1 ISIS level1, L2 ISIS level2, ia ISIS
inter area
* candidate default, U peruser static route, o ODR
P periodic downloaded static route
Gateway of last resort is not set
11.0.0.0/24 is subnetted, 1 subnets
C 11.11.11.0 is directly connected, FastEthernet0/0
101.0.0.0/24 is subnetted, 1 subnets
R 101.101.101.0 [120/1] via 11.11.11.2, 00:00:22,
FastEthernet0/0
SaktiR1#
Sakti-R3 dengan Sakti-R4 untuk tipe OSPF
SaktiR3(config)#router ospf 1
SaktiR3(configrouter)#net 12.12.12.0 0.0.0.255 area 0
SaktiR3(configrouter)#network 102.102.102.0 0.0.0.255 area 0
SaktiR3(configrouter)#exit
SaktiR3(config)#
SaktiR4(config)#router ospf 1
SaktiR4(configrouter)#network 12.12.12.0 0.0.0.255 area 0
SaktiR4(configrouter)#exit
SaktiR4(config)#
Cek output routng table di Sakti-R4
SaktiR4#show ip route
Codes: C connected, S static, I IGRP, R RIP, M
mobile, B BGP
D EIGRP, EX EIGRP external, O OSPF, IA OSPF inter area
N1 OSPF NSSA external type 1, N2 OSPF NSSA external type 2
E1 OSPF external type 1, E2 OSPF external type 2, E EGP
i ISIS, L1 ISIS level1, L2 ISIS level2, ia ISIS
inter area
* candidate default, U peruser static route, o ODR
P periodic downloaded static route
Gateway of last resort is not set
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, FastEthernet0/0
102.0.0.0/24 is subnetted, 1 subnets
O 102.102.102.0 [110/2] via 12.12.12.1, 00:03:26,
FastEthernet0/0
SaktiR4#
Sakti-R5 dengan Sakti-R6 untuk tipe EIGRP
SaktiR5(config)#router eigrp 10
SaktiR5(configrouter)#network 13.13.13.0
SaktiR5(configrouter)#no autosummary
SaktiR5(configrouter)#exit
SaktiR5(config)#
SaktiR6(config)#router eigrp 10
SaktiR6(configrouter)#network 13.13.13.0
SaktiR6(configrouter)#network 103.103.103.0
SaktiR6(configrouter)#no autosummary
SaktiR6(configrouter)#exit
SaktiR6(config)#
Cek output routng table di Sakti-R4
SaktiR5#show ip route
Codes: C connected, S static, I IGRP, R RIP, M
mobile, B BGP
D EIGRP, EX EIGRP external, O OSPF, IA OSPF inter area
N1 OSPF NSSA external type 1, N2 OSPF NSSA external type 2
E1 OSPF external type 1, E2 OSPF external type 2, E EGP
i ISIS, L1 ISIS level1, L2 ISIS level2, ia ISIS
inter area
* candidate default, U peruser static route, o ODR
P periodic downloaded static route
Gateway of last resort is not set
13.0.0.0/24 is subnetted, 1 subnets
C 13.13.13.0 is directly connected, FastEthernet0/0
103.0.0.0/24 is subnetted, 1 subnets
D 103.103.103.0 [90/30720] via 13.13.13.2, 00:31:01,
FastEthernet0/0
SaktiR5#
Sakti-R7 dengan Sakti-R8 untuk tipe Static routing. Konfigurasikan static default di Sakti-R7 dan di Sakti-R8 konfigurasikan static routing dan static defult route. Di Sakti-R7 dikonfigurasikan hanya static default route dikarenakan Sakti-R7 sudah directly connected network.
SaktiR7(config)#ip route 0.0.0.0 0.0.0.0 104.104.104.2
SaktiR7(config)#
SaktiR8(config)#ip route 104.104.104.0 255.255.255.0 14.14.14.1
SaktiR8(config)#ip route 0.0.0.0 0.0.0.0 14.14.14.1
SaktiR8(config)#
Cek output routng table di Sakti-R4
SaktiR8#show ip route
Codes: C connected, S static, I IGRP, R RIP, M
mobile, B BGP
D EIGRP, EX EIGRP external, O OSPF, IA OSPF inter area
N1 OSPF NSSA external type 1, N2 OSPF NSSA external type 2
E1 OSPF external type 1, E2 OSPF external type 2, E EGP
i ISIS, L1 ISIS level1, L2 ISIS level2, ia ISIS
inter area
* candidate default, U peruser static route, o ODR
P periodic downloaded static route
Gateway of last resort is 14.14.14.1 to network 0.0.0.0
14.0.0.0/24 is subnetted, 1 subnets
C 14.14.14.0 is directly connected, FastEthernet0/0
104.0.0.0/24 is subnetted, 1 subnets
S 104.104.104.0 [1/0] via 14.14.14.1
S* 0.0.0.0/0 [1/0] via 14.14.14.1
SaktiR8#
Selanjutnya kita setting konfigurasi redistributions di Sakti-R9. Pertama,konfigurasikan routing tipe RIPv2 yang mengarah ke Sakti-R2. Masih dalam mode routing RIPV2, langsung redistribute tipe routing RIPv2 tersebut dengan tipe routing lain yang ada.
SaktiR9(config)#router rip
SaktiR9(configrouter)#version 2
SaktiR9(configrouter)#network 101.101.101.0
SaktiR9(configrouter)#no autosummary
SaktiR9(configrouter)#redistribute ospf 1 metric 1
SaktiR9(configrouter)#redistribute eigrp 10 metric 1
SaktiR9(configrouter)#redistribute static
SaktiR9(configrouter)#exit
SaktiR9(config)#
Kedua, konfigurasikan routing tipe OSPF yang mengarah ke Sakti-R3. Masih dalam mode
routing OSPF 1, langsung reditribute tipe OSPF tersebut dengan tipe routing lain.
SaktiR9(config)#router ospf 1
SaktiR9(configrouter)#net 102.102.102.0 0.0.0.255 area 0
SaktiR9(configrouter)#redistribute rip subnets
SaktiR9(configrouter)#redistribute eigrp 10 subnets
SaktiR9(configrouter)#redistribute static subnets
SaktiR9(configrouter)#exit
SaktiR9(config)#
Ketiga, konfigurasikan routing tipe EIGRP yang mengarah ke Sakti-R6. Masih dalam mode routing EIGRP, langsung reditribute tipe EIGRP tersebut dengan tipe routing lain.
SaktiR9(config)#router eigrp 10
SaktiR9(configrouter)#network 103.103.103.0
SaktiR9(configrouter)#no autosummary
SaktiR9(configrouter)#redistribute rip metric 1 1 1 1 1
SaktiR9(configrouter)#redistribute ospf 1 metric 1 1 1 1 1
SaktiR9(configrouter)#redistribute static
SaktiR9(configrouter)#exit
SaktiR9(config)#
Cek output routing protocol di Sakti-R9
SaktiR9#show ip route
Codes: C connected, S static, I IGRP, R RIP, M
mobile, B BGP
D EIGRP, EX EIGRP external, O OSPF, IA OSPF inter area
N1 OSPF NSSA external type 1, N2 OSPF NSSA external type 2
E1 OSPF external type 1, E2 OSPF external type 2, E EGP
i ISIS, L1 ISIS level1, L2 ISIS level2, ia ISIS
inter area
* candidate default, U peruser static route, o ODR
P periodic downloaded static route
Gateway of last resort is not set
11.0.0.0/24 is subnetted, 1 subnets
R 11.11.11.0 [120/1] via 101.101.101.1, 00:00:00,
FastEthernet0/0
12.0.0.0/24 is subnetted, 1 subnets
O 12.12.12.0 [110/2] via 102.102.102.1, 01:09:10,
FastEthernet0/1
13.0.0.0/24 is subnetted, 1 subnets
D 13.13.13.0 [90/30720] via 103.103.103.1, 01:09:59,
FastEthernet1/0
14.0.0.0/24 is subnetted, 1 subnets
S 14.14.14.0 [1/0] via 104.104.104.1
101.0.0.0/24 is subnetted, 1 subnets
C 101.101.101.0 is directly connected, FastEthernet0/0
102.0.0.0/24 is subnetted, 1 subnets
C 102.102.102.0 is directly connected, FastEthernet0/1
103.0.0.0/24 is subnetted, 1 subnets
C 103.103.103.0 is directly connected, FastEthernet1/0
104.0.0.0/24 is subnetted, 1 subnets
C 104.104.104.0 is directly connected, FastEthernet1/1
SaktiR9#
Cek pula protocol routing di Sakti-R9
SaktiR9#show ip protocols
Routing Protocol is "eigrp 10 "
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 10, rip , ospf 1 , static
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
103.0.0.0
Routing Information Sources:
Gateway Distance Last Update
103.103.103.1 90 782
Distance: internal 90 external 170
ending updates every 30 seconds, next due in 14 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip, eigrp 10, ospf 1 , static
Default version control: send version 2, receive 2
Interface Send Recv
Triggered RIP Keychain
FastEthernet0/0 2
2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
101.0.0.0
Passive Interface(s):
Routing Information Sources:
Gateway
Distance
Last Update
101.101.101.1
120
00:00:21
Distance: (default is 120)
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 104.104.104.2
It is an autonomous system boundary router
Redistributing External Routes from,
rip
eigrp 10
static
Number of areas in this router is 1. 1 normal 0 stub 0
nssa
Maximum path: 4
Routing for Networks:
102.102.102.0 0.0.0.255 area 0
Routing Information Sources:
Gateway
Distance
12.12.12.2
110
102.102.102.1
110
104.104.104.2
110
Distance: (default is 110)
Last Update
00:09:07
00:09:03
00:09:01
SaktiR9#
Terakhir, bisa kita cek dengan ping antar router.
Sakti-R1 ping Sakti-R8
SaktiR1#ping 14.14.14.2
Type escape sequence to abort.
Sending 5, 100byte ICMP Echos to 14.14.14.2, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), roundtrip min/avg/max =
29/34/45 ms
SaktiR1#
إرسال تعليق